Unable to access firezone via HTTP

@jamil , I am trying docker setup but without SSL


when I access http URL, it will auto redirect to HTTPS

curl -v http://my_public_ip

  • Trying my_public_ip:80…
  • Connected to my_public_ip (my_public_ip) port 80 (#0)

GET / HTTP/1.1
Host: my_public_ip
User-Agent: curl/7.87.0
Accept: /

  • Mark bundle as not supporting multiuse
    < HTTP/1.1 308 Permanent Redirect
    < Connection: close
    < Location: https://my_public_ip/
    < Server: Caddy
    < Date: Thu, 29 Dec 2022 18:45:39 GMT
    < Content-Length: 0
  • Closing connection 0

Is it mandatory to have SSL?

HTTPS is highly recommended. We don’t support disabling it with the automatic install script – you’ll need to customize a few things. Try this:

In $HOME/.firezone/docker-compose.yml:

  • Change https:// to http:// in the Caddy config
  • Add SECURE_COOKIES: false in the firezone service definition

In $HOME/.firezone/.env:

  • Remove the TLS_OPTS var

Be warned – unless your connection to the web UI is encrypted via some other means, your credentials will be transmitted in the clear. So disable HTTPS at your own risk. Hope this helps.

Thanks @jamil , its just for test purpose I need this.

I am trying out the docker option to migrate from Omnibus setup, my main requirement is to disable WIREGUARD_IPV4_MASQUERADE with docker setup and without macvlan, do you if anyone has done this?