Installation script doesn't work

Hello there,

I have a small PC where I’d like to try Firezone on.
It is running Debian 11 with nothing else on it.
I am trying to run the installation script as per instructions, but the script doesn’t return anything.
Once the command is sent, the machine seems to be doing something for a couple of seconds, then nothing happens.

Could you please let me know how to proceed?

Can you paste exactly was was ran and what it looked like in the console?


I SSH’d to the machine. After logging in, the machine showed:

dod@ (with a blinking cursor)

I copied/pasted the following:

bash <(curl -Ls

The prompt returned exactly what it was showing before:

dod@ (with a blinking cursor)

Also tried with root user, same result.

What about if you download and execute the script?

wget && \
chmod +x && \

Exactly the same result. I’m baffled!

Hmmm try editing the second line of the install script from set -e to set -xe and we should see which command it fails at.

dod@$ ./ +

++ uname -s
+ os=Linux
+ '[' '!' Linux = Linux ']'
+ curlCheck
+ type curl
++ od -vN 8 -An -tx1 /dev/urandom
++ tr -d ' \n'
++ echo
+ telemetry_id=4b5107ec35734a24
++ curl --silent
+ public_ip=REDACTED
+ capture install email-not-collected@dummy.domain
+ type curl
+ '[' '!' -z 4b5107ec35734a24 ']'
+ curl -s -XPOST -H 'Content-Type: application/json' -d '{
          "api_key": "phc_ubuPhiqqjMdedpmbWpG2Ak3axqv5eMVhFDNBaXl9UZK",
          "event": "install",
          "properties": {
            "distinct_id": "4b5107ec35734a24",
            "email": "email-not-collected@dummy.domain"

@dod Ah – yeah I see the issue. The curl call is failing silently. I just updated the install script to bypass this for any errors. Give it a show now :-).