How to Disable HTTPS / Caddy ? (already have reverse proxy w/ SSL on router)

Hello, I have a fresh install on a Ubuntu VM with docker, and although everything is working well, I am hitting a stumbling block with caddy and SSL. Basically, I already have reverse proxy (HA proxy with ACME) setup on my pfsense router/firewall. I’m unable to get the firezone web page to load with the 2 reverse proxies in front of it (gives me SSL errors in the browser). Essentially, I don’t need Caddy nor SSL as is the default setup in the docker container. So I’ve been looking to disable it. I tried making the changes in the docker .yml and .env files as mentioned here: Caddy in reverse proxy and Nginx as front-end - #6 by BeWog But it just doesn’t work. I’ve made the changes and rebooted the VM to if it helped apply the changes. I’ve opened ports 81 and 13000 in the ubuntu firewall. In the browser from my other computer it says “Client sent an HTTP request to an HTTPS server.” So it seems Caddy is still running since SSL is still enabled (even though I’ve commented it out entirely from docker-compose.yml)? I am at my wits end. My other HTTP apps like Jellyfin and Authentik work fine behind my pfsense HA proxy via HTTPS. Please tell me what I’m missing … how to disable HTTPS/SSL from the default docker Firezone install. Thank you.

1 Like

Exactly! Having the exact same issue. Stupid caddy doesn’t seem to support turning off the auto https redirects and insists on using an https address it will never be able to use. Just use http damn it caddy, you’re behind NAT!