How to disable 80 on internet?

Hi all,

I have a running firezone on my firewall. This one is listen on internet with the 80 port.
I have a haproxy behind my firewall, so I forward 80/443 to this one.

I would like to disable caddy listening 80 directly on the internet. But If I change my firewall dns from public ip to private IP, I have errors in WAN Connectivity Checks.

How can I do it ?