How to create Firezone in VPS

I put Firestone on a VPS hosted by linode. I couldn’t get the fqnd thing working so I just connected to the UI via the server’s ip address. The UI rendered but it was unable to establish the websocket connection.

Hey @Apexio thanks for the report!

The WebSocket connection is fairly strict to prevent CSWH – it works best when you have a valid SSL cert and FQDN.

We’re working on relaxing it a bit so that self-signed certs and IP addresses will work. That should be fixed and pushed within the next day or two.

In the meantime, have you tried setting your server’s IP in the fqdn setting in /etc/firezone/firezone.rb?

How exactly do I get an ssl certificate? I have tried, but I don’t think it works with an ip address. I added the ip address as a subdomain to one of my domains and generate a certificate for that but then it shows this.

And yes, I did try that. It didn’t change anything. Also, how do I set the fqdn on Ubuntu 21.10?

Actually I managed to fix it. Thank you.