Disabling masquerade breaks all traffic

when I add WIREGUARD_IPV4_MASQUERADE=false to my .env file and re up the docker containers. All traffic over the vpn connection breaks.

Troubleshooting has been limited. I can still connect fine but no traffic will leave the vpn host. I can ping the address pool gateway and that’s it. Fairly confident its not a local network or firewalling issue as no traffic leaves the vpn host. If comment out the line and re up traffic is fine but is NATd to the hosts IP.

Have you enabled ip forward?
sysctl -w net.ipv4.ip_forward=1 for runtime change, net.ipv4.ip_forward = 1 in /etc/sysctl.conf in order to allow it surviving the reboot.

Hi, I have the same issue. WIREGUARD_IPV4_MASQUERADE=false stops all traffic from going out.

Ip forwarding is enabled in docker compose

      # Needed for masquerading and NAT.
      - net.ipv6.conf.all.disable_ipv6=0
      - net.ipv4.ip_forward=1
      - net.ipv6.conf.all.forwarding=1

and checked in the container

/app # sysctl -a|grep net.ipv4.ip_forward
net.ipv4.ip_forward = 1
net.ipv4.ip_forward_update_priority = 1
net.ipv4.ip_forward_use_pmtu = 0

Try this: